Some extra information
Call us on 0131 538 4343

Not heating up ....?

This question is regarding Redring 650 Slimline Shower (2004 - Current) Shower Spares

Hi Guys,

This morning it worked fine but when it was switched off and it when through its normal controlled shutdown it spat and made a strange burbling noise ? It was then used again later but its not heating up anymore on any of the settings ? Any ideas ?

Cheers

Adrian


Asked 7 years ago by Anonymous
I think you may have a faulty Thermal Cut Out (TCO).

A faulty TCO will have no continuity across the two terminals (The black thing on top of the heating tank)

Therefore a good TCO will have power at both connections and a faulty TCO will have power at only one.

(The function of the TCO is, if the water over heats it cuts the power off to the elements until the water cools, this can take up to 15mins)See Video:www.youtube.com/user/showerdoc#p/u/2/_zi8JbEMYMs After fitting a new TCO When fitting a new TCO listen to the shower, after it has completed its first on/off cycle, if when it is switched off you hear it continuing to heat (Noise like a kettle starting to boil) this will mean that there is a switch or a relay that is stuck in the on position, this is keeping an element energised and this is probably what caused the original TCO to fail.If this is the case replace the faulty switch or relay and make sure that you switch the shower off at the isolating switch when the shower is not in use because this may cause the new TCO to fail.
Answered 7 years ago by Barrie Seabright
View Spares and Order Online:
View Spares

You send it, we mend it.