Some extra information
Call us on 0131 538 4343

Not heating

This question is regarding Triton Topaz T100si Shower Spares

I have a Triton t100 si. Pressure and display are fine but not heating.....Would this more than likely be the TCO?
Thanks.

Asked 2 years ago by Luke English
If the shower is absolutely cold then I think you may have a faulty Thermal Cut Out

A faulty TCO will have no continuity across the two terminals (The black thing on top of the heating tank)

Therefore a good TCO will have power at both connections and a faulty TCO will have power at only one.

(The function of the TCO is, if the water over heats it cuts the power off to the elements)

See Video.

www.youtube.com/user/showerdoc#p/u/2/_zi8JbEMYMs

If there is some heat it may be a faulty element in the heating tank (there are two, three in most 10kw showers) you can check them with a multi meter you should have a reading of around 12>18 ohms.

If you have power to the elements and no heat it's probably the elements, no power to the elements then it's probably a micro switch.


If you don’t have a multimeter we sell them at £10 each with a guide on how to use them for checking and testing the various parts of your shower.


Apart from helping to fix your shower, they are really useful for checking you have a power supply to appliances, for checking fuses, letting you know much power you have left in batteries

(so you know if they are dud or not) and lots of other jobs, in short they are well worth the £10.


www.showerdoc.com/installation/electrical-products/SKYTRO-600-005-Digital-Multi-Tester
Answered 2 years ago by George Thomson
View Spares and Order Online:
View Spares

You send it, we mend it.